foto1
foto1
foto1
foto1
foto1
86163-21571
pvi0806@yandex.ru

ЕГЭ-2018

Где используется Python?

ОГЭ-2018

Главное меню

Кумир

СИ++

Дан фрагмент программы, обрабатывающей двумерный массив A размера n? n.

Бейсик

Алгоритмический

k = 1
FOR i = 1 TO n
  c = A(i,k)
  A(i,k) = A(k,i)
  A(k,i) = c
NEXT i

k := 1
нцдля i от 1 до n
  c := A[i,k]
  A[i,k] := A[k,i]
  A[k,i] := c
кц

Паскаль

Си

k := 1;
for i:= 1 to n do begin
  c := A[i,k];
  A[i,k] := A[k,i];
  A[k,i] := c
end;

k:=1;
for(i=0;i<n;i++) {
  c = A[i][k];
  A[i][k] = A[k][i];
  A[k][i] = c;
}

Представим массив в виде квадратной таблицы, в которой для элемента массива A[i,j] величина i является номером строки, а величина j – номером столбца, в котором расположен элемент. Тогда данный алгоритм меняет местами

1) Элементы двух диагоналей

2) Элементы диагонали и k-й строки

3) Элементы диагонали и k-го столбца

4) Элементы k-й строки и k-го столбца

 


Задание 2

 

Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

 

Бейсик

Паскаль

Алгоритмический

FOR n=1 TO 100
A(n)=(n-75)*(n-75)
NEXT n
FOR n=1 TO 100
B(101-n)=A(n)
NEXT n

for n:=1 to 100 do
    A[n]:= (n-75)*(n-75);
for n:=1 to 100 do
    B[101-n]:=A[n];

нц для n от 1 до 100
    A[n]=(n-75)*(n-75)
кц
нц для n от 1 до 100
    B[101-n]=A[n]
кц

Какой элемент массива B будет наибольшим?

 

1)   B[1]

2)   B[26]

3)   B[75]

4)   B[100]

 

Задание 3

 

Элементы двумерного массива A размером NхN первоначально были равны 1000. Затем значения некоторых из них меняются с помощью вложенного оператора цикла в представленном фрагменте программы:

 

Бейсик

Паскаль

Алгоритмический

k:=0

FOR i=1 TO N

FOR j=N–i+1 TO N

k=k+1

A(i, j)=k

NEXT j

NEXT i

k:=0;

for i:=1 to N do

for j:=N–i+1 to N do

  begin

     k:=k+1;

    A[i, j]:=k;

  end

k:=0

нц для i от 1 до N

  нц для j от N–i+1 до N

    k:=k+1

    A[i, j]:=k

  кц

кц

 

Какой элемент массива в результате будет иметь минимальное значение?

 

1)   A(1, 1)

2)   A(1, N)

3)   A(N, 1)

4)   A(N, N)

 

 


Задание 4

 

Дан фрагмент программы, обрабатывающей массив A из n элементов (известно, что в массиве имеются положительные элементы):

 

Бейсик

Паскаль

s = 0
k = 0
FOR i = 1 TO n
IF A(i)>0 THEN

s = s+A(i) : k=k+1
ENDIF

NEXT i
s = s/k

s:=0;
k:=0;
for i:=1 to n do
begin

    if A[i]>0 then
    begin
        s:=s+A[i];
        k:=k+1
    end
end;

s:=s/k;

Си

Алгоритмический язык

s = 0;

k = 0;

for (i = 0; i<n ; i++)

  if (A[i]>0)

  {

    s=s+A[i];

    k++;

  }

s = s/k;

s:=0
k:=0
нц для i от 1 до n
    если A[i]>0 то
        s:=s+A[i]
        k:=k+1
    все
кц

s:=s/k

 

Чему будет равно значение переменной s после выполнения данного алгоритма?

 

1)

Среднему арифметическому всех элементов массива A

2)

Среднему арифметическому всех положительных элементов массива A

3)

Количеству положительных элементов в массиве A

4)

Значению последнего положительного элемента в массиве A

 

 

Паскаль